Checkout Issues in [Country] Identified
Incident Report for Tabby
Resolved
This incident has been resolved.
Posted May 21, 2024 - 14:05 UTC
Investigating
Dear Clients,

We'd like to inform you that we are currently experiencing issues with our checkout process, starting from 13:45 UTC in all countries. During this period, customers may encounter difficulties completing purchases.

Our team is actively addressing the matter to ensure a swift resolution. We apologize for any inconvenience.

We will keep you updated on the progress and appreciate your patience during this time.
Posted May 21, 2024 - 13:58 UTC
This incident affected: Checkout.